Excedo DMS Portal - Search Domains Non-Functional
Incident Report for Excedo Systems
Resolved
This incident has been resolved.
Posted Mar 13, 2024 - 17:03 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 13, 2024 - 16:32 CET
Investigating
We have gotten alarms concerning that our Search Domains function within our Excedo DMS Portal is currently non-functional.
We are currently investigating this issue and will update our statuspage accordingly.
Posted Mar 13, 2024 - 16:18 CET
This incident affected: Excedo DMS Portal (Order Service).