Mailscreen email
Incident Report for Excedo Systems
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 16:54 CEST
Monitoring
Customers may still experience mail delays as queues are processed.
Posted Jul 19, 2024 - 11:03 CEST
Identified
Mailsceen Portal is now accessible.

Currently we are investigating Mailflow delays that customers are still experiencing.
Posted Jul 19, 2024 - 10:47 CEST
Investigating
Mailscreen service are currently experiencing outage.

Mailscreen portal not accessible
Inbound email stuck in queue for delivery
Outbound email stuck in queue for delivery

ETA is currently unknown awaiting response from technical team.
Posted Jul 19, 2024 - 09:05 CEST
This incident affected: Excedo Mailscreen.