Excedo DMS Portal - Order Service not working
Incident Report for Excedo Systems
Resolved
This incident has been resolved.
Posted Apr 11, 2023 - 12:25 CEST
Investigating
We have gotten alarms concerning that it is currently not possible to place domain orders during checkout.
We are currently investigating this issue and will update our statuspage accordingly.
Posted Apr 11, 2023 - 11:23 CEST
This incident affected: Excedo DMS Portal (Order Service).